1. Home
  2. Knowledge Base
  3. Connectivity
  4. Compatibility operating systems

Compatibility operating systems

The Corsano app is compatible with most popular phones and tablets. To set up and use a Corsano device, the user must install the Corsano app on a compatible phones and tablets running one of the following operating systems:

  • Apple iOS 14 or higher
  • Android OS 8.0 or higher

The following phones and tablets are compatible with Corsano applications. We are adding more phones and tablets when they become available.

Apple phones and tablets

iPhone 11 and aboveiPhone 7 Plus
iPhone 11 ProiPhone 7
iPhone 11 Pro MaxiPhone SE
iPhone XS MaxiPhone 6S Plus
iPhone XSiPhone 6S
iPhone XRiPhone 6 Plus
iPhone XiPhone 6
iPhone 8 PlusiPod Touch 6th gen
iPhone 8

Android phones and tablets


Google
Nexus 5xPixelPixel 3
Nexus 6pPixel XLPixel 3 XL
Pixel 2Pixel 4
Pixel 2 XL

Huawei
Honor 8P20 ProMate 20
P30 ProP10Mate 9
P30
P30 Lite


LG
G6G8


Motorola
X4Moto Z
G5SMoto Z4


OnePlus
OnePlus 6OnePlus 7 Pro


Oppo
R17 ProRenoReno Z


Samsung
Galaxy S10Galaxy S8Galaxy Note 9
Galaxy S10+Galaxy A8Galaxy A10
Galaxy S10eGalaxy S7 EdgeGalaxy S10 5G
Galaxy S9+Galaxy S7
Galaxy S9Galaxy J3 (only after 2017)
Galaxy S8+Galaxy A6


Sony
Xperia XZ2Xperia XZ

Due to Bluetooth issues that prevent Corsano devices from syncing, Corsano’s products are not compatible with the following mobile phones:

  • Huawei P8 Lite
  • Huawei P9 Lite
  • Xiaomi Mi 6
  • Huawei P20 Lite
Was this article helpful?

Need Support?

Can't find the answer you're looking for?
Contact Support
Translate